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Computer Science 

Unit: 4th  

VISUAL FOXPRO 

Overview of Visual Foxpro 

• Visual FoxPro (VFP) is an object-oriented programming language and data 

management system developed by Microsoft. 

• VFP was designed for creating database applications and it's known for its speed 

and ability to handle large amounts of data. 

• VFP was first released in 1992 and the latest version was 9.0 which was released 

in 2007. 

• VFP is a powerful tool for creating standalone applications, as well as client-server 

and web-based systems. 

• VFP allows to create of forms, reports, and other visual elements with the included 

form and report designer. 

• VFP features a SQL-based query language, which allows for efficient data retrieval 

from tables and queries. 

• VFP allows to create of user-defined functions, procedures, and classes to 

encapsulate complex logic and reuse code. 

• VFP allows the creation and maintains indexes and relationships between tables 

to improve performance and data integrity. 

• VFP has support for various data types such as strings, numbers, dates, and logical 

data. 

• VFP supports the use of object-oriented programming techniques, such as 

inheritance, polymorphism, and encapsulation. 

• VFP has a visual development environment, which includes a variety of tools and 

wizards to simplify the development process. 

• Microsoft ended its support for VFP in 2015. 

• Nowadays, most developers use other languages and platforms for development 

such as .NET, Java, Python, etc. 
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Characteristics of Visual FoxPro 

• Object-Oriented: VFP is an object-oriented programming language, which allows 

for the creation of user-defined classes, objects, and methods. 

• Data-Centric: VFP is designed to work with data and allows the creation and 

maintenance of tables, queries, and indexes. 

• SQL-based: VFP includes a SQL-based query language that allows for efficient 

data retrieval from tables and queries. 

• Rapid Application Development: VFP allows for rapid application development 

with the use of tools and wizards for creating forms, reports, and other visual 

elements. 

• Visual Development Environment: VFP features a visual development 

environment that includes a variety of tools and wizards to simplify the 

development process. 

• Support for Multiple Data Types: VFP supports various data types such as strings, 

numbers, dates, and logical data. 

• Support for Object-Oriented Programming Techniques: VFP supports the use of 

object-oriented programming techniques, such as inheritance, polymorphism, and 

encapsulation. 

• Support for User-Defined Functions: VFP allows the creation of user-defined 

functions, procedures, and classes to encapsulate complex logic and reuse code. 

• Support for Data Integrity and Referential Integrity: VFP allows for the 

enforcement of data integrity constraints such as primary key, foreign key, and 

check constraints. 

• Support for Data Relationships: VFP allows for the creation of complex 

relationships between tables through the use of primary keys and foreign keys. 

• Support for Data Security: VFP provides a wide range of security features such as 

user authentication and access control. 
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• Support for Data Consistency: VFP ensures that the data in the database is 

consistent by maintaining referential integrity. 

• Support for Scalability: VFP allows for easy scaling of the database by adding more 

tables, fields, and indexes. 

• Not supported anymore: Microsoft ended its support for VFP in 2015. 

DBMS is a basic system for storing and retrieving data, an RDBMS is a more advanced 

system that allows for the creation of complex relationships between tables and the 

enforcement of data integrity through the use of constraints and indexes. 

 

Introduction to Visual FoxPro: The menu system, file types, The 

Toolbars, Visual Design and Wizards, The Command Window and View 

window, and Other features of the Visual FoxPro interface. 

 

Visual FoxPro is a relational database management system and programming language 

developed by Microsoft. It has a variety of features designed to make it easy to create and 

manage databases, forms, and reports. 

1. The menu system: Visual FoxPro has a menu-driven interface that allows users to 

access all of the program's features and functions. The main menu bar at the top 

of the screen provides access to various options, such as file management, data 

manipulation, and report creation. 

2. File types: Visual FoxPro supports a variety of file types, including tables, queries, 

forms, and reports. This allows users to easily import, export, and manipulate data 

in a variety of formats. 

3. Toolbars: Visual FoxPro includes a variety of toolbars that provide quick access to 

frequently used commands and features. These toolbars can be customized to 

include only the tools that are needed for a particular task. 

4. Visual Design and Wizards: Visual FoxPro includes a visual design feature that 

allows users to easily create and modify forms and reports using drag-and-drop 

functionality. It also includes wizards that guide users through the process of 

creating specific types of forms and reports. 

5. The Command Window and View window: The Command Window allows users 

to enter and execute FoxPro commands directly, whereas the View window is 

used to view and edit the code of a specific form, report, or program. 
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6. Other features: Visual FoxPro also includes features such as a built-in 

programming language, support for multiple data sources, and the ability to create 

and run programs in a variety of languages. It also has a feature called the "project 

manager" which allows user to organize their projects and files in a logical manner. 

Visual FoxPro is a powerful and versatile tool for creating and managing databases, 

forms, and reports. Its user-friendly interface, visual design features, and wizards make 

it easy for users to create and manipulate data. 

 

Tables in Visual FoxPro: Create a new Table, Table wizard, using 

Table Designer, Using Tables, opening a table, Working on a table, 

Modifying a table 

Tables are an essential component of any database, and Visual FoxPro provides several 

tools for creating, managing, and working with tables. Here are some key features of 

working with tables in Visual FoxPro: 

1. Create a new Table: Users can create a new table in Visual FoxPro by selecting the 

"File" menu and choosing "New" > "Table". They can also use the Table Wizard, 

which guides them through the process of creating a new table. 

2. Table wizard: The Table Wizard allows users to create a new table by specifying 

the fields, data types, and properties for each field. It also allows them to specify 

relationships between tables and to set up indexes and validation rules. 

3. Using Table Designer: Table Designer is a visual tool that allows users to create 

and modify tables. It provides a graphical interface for specifying fields, data 

types, and properties, and allows users to set up relationships, indexes, and 

validation rules. 

4. Opening a table: Users can open a table by selecting it from the "File" menu and 

choosing "Open" > "Table", or by double-clicking on the table in the Project 

Manager. 

5. Working on a table: Once a table is open, users can view and edit its data, add or 

delete records, and modify the structure of the table. They can also use the built-

in data validation and editing features to ensure that data is entered correctly. 

6. Modifying a table: Users can modify a table by adding or removing fields, 

changing the data type of a field, or modifying the properties of a field. They can 

also use Table Designer to make these changes. 
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 Visual FoxPro provides a variety of tools for working with tables, making it easy 

for users to create, modify, and manage their data. The Table Wizard, Table 

Designer, and other features provide a user-friendly interface for working with 

tables and ensure that data is entered correctly. 

 

Managing Data: Switching from Browse to Edit display, Entering and 

Editing Data, appending data, editing data, moving through a Table, Go 

To Record commands, Find and Replace, delete a Record, Altering the 

Display of the Browse Window 

 

Visual FoxPro provides several tools for managing data in tables, including the ability to 

switch between Browse and Edit display modes, enter and edit data, move through a 

table, and perform various other operations. Here are some key features of managing 

data in Visual FoxPro: 

1. Switching from Browse to Edit display: Users can switch between Browse and Edit 

display modes by selecting the "View" menu and choosing "Browse" or "Edit". In 

Browse mode, users can view the data in a table, but cannot edit it. In Edit mode, 

users can edit the data in a table. 

2. Entering and Editing Data: Users can enter and edit data in a table by switching to 

Edit mode and entering data into the fields. They can also use the built-in data 

validation and editing features to ensure that data is entered correctly. 

3. Appending data: Users can add new records to a table by selecting "File" > 

"Append" or by using the Append Blank button in the Browse window. 

4. Moving through a Table: Users can move through a table by using the navigation 

buttons in the Browse window or by using keyboard shortcuts. The Go To Record 

command allows users to move to a specific record in a table. 

5. Find and Replace: Users can search for specific data in a table and replace it with 

new data using the Find and Replace feature. This feature can be accessed from 

the "Edit" menu. 

6. Deleting a Record: Users can delete records from a table by selecting the record 

and pressing the Delete key, or by using the Delete Record button in the Browse 

window. 
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7. Altering the Display of the Browse Window: Users can change the way the data is 

displayed in the Browse window by altering the font size, column width, and other 

display options. They can also change the order of the columns and sort the data. 

Visual FoxPro provides a variety of tools for managing data in tables, including the ability 

to switch between Browse and Edit display modes, enter and edit data, move through a 

table, and perform various other operations. Users can easily search, replace, delete, and 

modify the data according to their requirements. 

 

Using Queries: Creating a Query Wizard, Query Designer, Running the 

Query, Using the Query, the Cross Tab Wizard, Modifying the 

Query, The Query Designer. 

 

In Visual FoxPro, Queries are used to extract specific information from one or more 

tables. The Query Wizard and Query Designer are tools that allow the user to create and 

modify queries. The Query Wizard guides the user through the process of creating a 

query by asking a series of questions. The Query Designer allows the user to create and 

modify queries by visually designing the query structure. 

Once a query is created, it can be run by clicking the "Run" button or by entering the 

query name in the Command Window. The results of the query are displayed in the View 

Window. The user can then use the data in the query for further analysis or to create 

reports. 

In Visual FoxPro, you can create a query using the Query Wizard. To do this, follow these 

steps: 

1. Open the Database Designer by going to the File menu and selecting "New." 

2. In the Database Designer, select "Query" from the list of options. 

3. Click the "Wizard" button to launch the Query Wizard. 

4. Follow the prompts in the wizard to select the tables and fields you want to include 

in the query. 

5. Use the options in the wizard to specify any sorting or filtering criteria you want 

to apply to the query. 

6. Give the query a name and click "Finish" to create the query. 

Once you have created the query, you can use it to retrieve data from the tables you 

selected in the wizard. You can also modify the query's design in the Database Designer. 
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Running the Query 

Once you have created a query in Visual FoxPro, you can run it to retrieve the data that 

it is designed to retrieve. To run a query, you can follow these steps: 

1. Open the Database Designer by going to the File menu and selecting "New." 

2. In the Database Designer, select the query you want to run from the list of options. 

3. Click the "Run" button, or press the F5 key, to execute the query. 

The results of the query will be displayed in the Data Session window, which will open 

automatically when you run the query. You can use the tools in the Data Session window 

to view, sort, and export the query's results. 

Alternatively, you can also use the SQL SELECT statement to run the query and retrieve 

data from the database. 

You can also use the command "USE" followed by the query name to use the query and 

retrieve data from the database. 

Example: 

USE MyQuery  

This will open the query and will retrieve the data based on the query definition. 

 

Using the Query with the Cross Tab Wizard 

In Visual FoxPro, you can use the Cross Tab Wizard to create a cross-tabulation query, 

also known as a crosstab query, which allows you to view and analyze data in a pivot 

table format. A crosstab query is a special type of query that aggregates data across 

multiple fields and groups the results by one or more fields. To use a query with the Cross 

Tab Wizard, you can follow these steps: 

1. Open the Database Designer by going to the File menu and selecting "New." 

2. In the Database Designer, select the query you want to use with the Cross Tab 

Wizard from the list of options. 

3. Click the "Wizard" button to launch the Cross Tab Wizard. 

4. Follow the prompts in the wizard to select the fields you want to use for the rows, 

columns, and values of the crosstab query. 

5. Use the options in the wizard to specify any sorting or filtering criteria you want 

to apply to the crosstab query. 

6. Give the crosstab query a name and click "Finish" to create the query. 
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Once you have created the crosstab query, you can run it to retrieve the data that it is 

designed to retrieve, in the format of a pivot table. You can also modify the crosstab 

query's design in the Database Designer. 

Alternatively, you can use the SQL SELECT statement with the GROUP BY clause and 

aggregate functions like COUNT, SUM, AVG, etc, to create a crosstab query. 

For Example: 

SQL 

SELECT field1, field2, COUNT (field3) FROM table1 GROUP BY field1, field2  

This will group the data based on field 1 and field 2 and will count field 3, which will 

give you the results in crosstab format. 

 

Modifying the Query 

Once you have created a query in Visual FoxPro, you can modify it to change the tables, 

fields, sorting, and filtering criteria that it uses to retrieve data. To modify a query, you 

can follow these steps: 

1. Open the Database Designer by going to the File menu and selecting "New." 

2. In the Database Designer, select the query you want to modify from the list of 

options. 

3. Make any changes you want to the query's design. You can add or remove tables, 

fields, or criteria, change the way the query's results are sorted, and more. 

4. Save the changes you've made to the query by clicking the "Save" button, or by 

going to the File menu and selecting "Save." 

Alternatively, you can also use the SQL Select statement to modify the query. 

For Example : 

vbnet 

SELECT field1, field2, field3 FROM table1 WHERE field1=value1 ORDER BY field2  

You can also use the SQL UPDATE statement to update the existing data in the database 

based on the query. 

Example: 

sql 

UPDATE table1 SET field1=newvalue1 WHERE field2=value2  

This will update the existing data in the table1 where field2 is value2 and set field1 to 

newvalue1 

Once you've modified the query, you can run it again to retrieve the updated data. 
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Cross Tab Wizard 

The Cross Tab Wizard is a tool that allows the user to create a cross-tabulation query, 

which is a query that displays data in a tabular format. The user can modify the query by 

using the Query Designer, which allows the user to select specific fields, set conditions, 

and specify sort orders. 

Overall, Queries are an essential tool in Visual FoxPro, they allow you to extract the 

specific data that you need and make it easy to work with large sets of data. 

 

Datatypes 

In Visual FoxPro 6.0, data types are used to define the type of data that a variable or field 

can hold. The most commonly used data types in Visual FoxPro 6.0 include: 

• Character: A character is a sequence of characters used to store text data. It is 

denoted by the "C" in the field definition. 

• Numeric: A numeric data type is used to store numeric values. It is denoted by the 

"N" in the field definition. 

• Date: A date data type is used to store date and time values. It is denoted by the 

"D" in the field definition. 

• Logical: A logical data type is used to store Boolean values (True or False). It is 

denoted by the "L" in the field definition. 

• Currency: A currency data type is used to store monetary values. It is denoted by 

the "Y" in the field definition. 

• Memo: A memo data type is used to store large amounts of text data. It is denoted 

by the "M" in the field definition. 

• Integer: An integer data type is used to store whole numbers. It is denoted by the 

"I" in the field definition. 

It's important to choose the appropriate data type when creating variables and fields in 

your FoxPro program in order to ensure that the data is stored and used correctly. 

 

Visual FoxPro 6.0, operators 

In Visual FoxPro 6.0, operators are used to perform various operations on data and 

variables. Some of the most commonly used operators in Visual FoxPro 6.0 include: 

• Arithmetic operators: These operators perform basic arithmetic calculations such 

as addition (+), subtraction (-), multiplication (*), and division (/). 
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• Comparison operators: These operators compare two values and return a logical 

value based on the comparison. They include equal to (==), not equal to (<>), 

greater than (>), less than (<), greater than or equal to (>=), and less than or equal 

to (<=). 

• Logical operators: These operators perform logical operations such as AND, OR 

and NOT. They are used to combine multiple comparisons or conditions. 

• Concatenation operator: This operator is used to join two or more strings together. 

The operator is the ampersand symbol (&). 

• Conditional operator: This operator is used to assign a value based on a condition. 

The operator is the question mark ( ? ). 

• Membership operator: This operator is used to test for the presence of a value 

within a range or a set of values. The operator is the IN keyword. 

• Like operator: This operator is used to match a string against a pattern. It uses the 

wildcard characters * and ?. The operator is the LIKE keyword. 

It's important to use the correct operator for the operation you're trying to perform, in 

order to avoid errors in your code and to get the desired result. 

 

Components of Visual Foxpro Database  

 

A Visual FoxPro database is made up of several components that work together to store, 

manage, and retrieve data. These components include: 

• Tables: Tables are the basic building blocks of a Visual FoxPro database and are 

used to store data in a tabular format. Each table has a set of fields (columns) that 

define the types of data that can be stored in the table, and a set of records (rows) 

that contain the actual data. 

• Fields: Fields are the individual columns within a table that define the types of 

data that can be stored in the table. Each field has a name and a data type, such as 

string, number, date, or logical. 

• Indexes: Indexes are used to speed up the retrieval of data from tables. They are 

like a "road map" that helps Visual FoxPro quickly find specific records in a table. 

Indexes can be created on one or more fields in a table and can be either ascending 

or descending. 
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• Queries: Queries are used to retrieve specific data from one or more tables based 

on a set of conditions. They are created using SQL (Structured Query Language) 

and can be used to filter, sort, and join data from multiple tables. 

• Forms: Forms are used to create user interfaces for data entry and editing. They 

allow users to interact with the data in a table by displaying the fields in a visually 

pleasing way, and providing features such as data validation, navigation, and data 

entry. 

• Reports: Reports are used to present data in a formatted, easy-to-read way. They 

can be created using the Report Designer, which allows users to customize the 

layout, font, and other formatting options. 

• Procedures: Procedures are blocks of code that can be called by other code to 

perform specific tasks. They can be used to encapsulate complex logic, reduce code 

duplication, and improve the maintainability of a program. 

• Classes: Classes are used to define the properties and methods of objects. They 

can be used to create a blueprint for objects, and to encapsulate data and behavior. 

All these components work together to store, manage, and retrieve data in a Visual 

FoxPro database. 

 

Create a database 

To create a database in Visual FoxPro 6.0, you can follow these steps: 

1. From the File menu, select New and then Database. 

2. In the New Database dialog box, specify the location and name of the new 

database. 

3. Select a data type for the database, such as dBase III, FoxPro 2.5, or Free Table. 

4. Click OK to create the new database. 

5. Once the new database is created, you can add tables to it by using the File > New 

> Table command, or by importing existing tables from other sources. 

6. To add fields to a table, you can use the Design option in the File menu. 

7. To add data to the table, you can use the Data option in the File menu. 

8. To create relationships between tables, you can use the Relationships option in the 

File menu. 

Visual FoxPro 6.0 is an old version and is not supported anymore. If you are planning 

to work with databases, it's recommended to use a more recent version of Visual FoxPro 

or other database management systems that have more advanced features and support. 
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Creating a Database: 

• To create a new database in Visual FoxPro 6.0, use the CREATE DATABASE 

command. The syntax for the command is: CREATE DATABASE databaseName 

• For example: CREATE DATABASE MyDB 

Adding new records: 

• To add new records to a table in Visual FoxPro 6.0, use the APPEND command. 

The syntax for the command is: APPEND BLANK 

• This will create a new blank record in the table. You can then use the REPLACE 

command to add data to the fields of the new record. 

Editing a record: 

• To edit a record in a table in Visual FoxPro 6.0, you can use the SEEK command to 

locate the record, and then use the REPLACE command to edit the fields of the 

record. 

• The syntax for the SEEK command is: SEEK search Expression 

• For example: SEEK "Ashok" 

• Once you have located the record, you can use the REPLACE command to edit the 

fields. The syntax for the REPLACE command is: REPLACE fieldName WITH 

newValue 

• For example: REPLACE Phone WITH "555-555-5555" 

 

Renaming a field: 

• To rename a field in a table in Visual FoxPro 6.0, you can use the MODIFY 

STRUCTURE command. The syntax for the command is: MODIFY STRUCTURE 

fieldName TO newField Name 

• For example: MODIFY STRUCTURE Phone TO Telephone 

Displaying a database: 

• To display the contents of a table in Visual FoxPro 6.0, you can use the BROWSE 

command. The syntax for the command is: BROWSE 

• This will open a Browse window that displays the contents of the table. You can 

also use the SELECT command to display the contents of a specific table or query. 

The syntax for the SELECT command is: SELECT tableName 

• For example SELECT Customers 
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Several Commands 

Visual FoxPro 6.0 is a programming language and database management system that 

includes a wide variety of commands for working with data and program flow. Some of 

the most commonly used commands in Visual FoxPro 6.0 include: 

• SELECT: opens a table or a query and makes it the current table. 

• USE: opens a table and makes it the current table. 

• BROWSE: opens a table in a browsable window. 

• CLOSE: closes a table or a query. 

• COPY TO: creates a copy of a table. 

• APPEND FROM: adds the data from one table to another table. 

• DELETE: deletes the current record or a selected set of records. 

• PACK: removes deleted records from a table. 

• ZAP: deletes all records from a table and resets the table's structure. 

• INDEX ON: creates an index on one or more fields of a table. 

• SET ORDER TO: sets the order of the records in a table. 

• GO TOP: moves to the first record of a table. 

• GO BOTTOM: moves to the last record of a table. 

• SKIP: moves a specified number of records forward or backward. 

• SEEK: locates a record in a table based on a value in one of its fields. 

• LOCATE: locates a set of records in a table based on a condition. 

• FIND: locates the first occurrence of 

 

Visual FoxPro 6.0 is a programming language and database management system that 

includes a wide variety of commands for working with data and program flow. Some 

of the most commonly used commands in Visual FoxPro 6.0 and their syntax include: 

• SELECT: opens a table or a query and makes it the current table. Syntax: SELECT 

[table name] 

• USE: opens a table and makes it the current table. Syntax: USE [table name] 

• BROWSE: opens a table in a browsable window. Syntax: BROWSE [table name] 

• CLOSE: closes a table or a query. Syntax: CLOSE [table name] 

• COPY TO: creates a copy of a table. Syntax: COPY TO [new table name] 

• APPEND FROM: adds the data from one table to another table. Syntax: APPEND 

FROM [table name] 
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• DELETE: deletes the current record or a selected set of records. Syntax: DELETE 

[condition] 

• PACK: removes deleted records from a table. Syntax: PACK [table name] 

• ZAP: deletes all records from a table and resets the table's structure. Syntax: ZAP 

[table name] 

• INDEX ON: creates an index on one or more fields of a table. Syntax: INDEX ON 

[field name] TO [index name] 

• SET ORDER TO: sets the order of the records in a 

• INDEX ON <fields> TAG <index name>: creates an index on one or more fields of 

a table. 

• SET ORDER TO <index name>: sets the order of the records in a table. 

• GO TOP: moves to the first record of a table. 

• GO BOTTOM: moves to the last record of a table. 

• SKIP <number of records>: moves a specified number of records forward or 

backward. 

• SEEK <value> 

Practice Question 

1. What are the different datatypes supported by Visual FoxPro and how are they 

used in programming? 

2. How does Visual FoxPro handle databases and what is the proprietary format 

used for storing data? 

3. Can you explain the structure of a table in Visual FoxPro and the difference 

between a record and a field? 

4. How does the query system work in Visual FoxPro and what are some examples 

of common query commands? 

5. What is the role of commands in Visual FoxPro and can you provide examples of 

commonly used commands? 

6. How does Visual FoxPro handle relationships between tables in a database? 

7. Can you explain how to create and modify a table in Visual FoxPro? 

8. What are the different types of datatypes in Visual FoxPro?  
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9. How does Visual FoxPro handle databases and tables, and what are the differences 

between records and fields?  

10. Can you explain the use of queries in Visual FoxPro, and provide examples of 

some common commands used in the language? 

 

 


